2
Es fragte jemand in mathefragen.de, warum die Seite nicht funktioniert.

Aktuell habe ich das gleiche Problem:

Wenn ich auf "Kommentar" klicke, öffnet sich das Eingabefenster nicht, in dem der Kommentar geschrieben werden müsste. Ich nutze Firefox auf einem Windows10-Laptop.
Da sich das Eingabefenster hier auf meta-fragen.de öffnet, sollte es nicht an meinem Browser liegen.
Ich habe es auch(!) im privaten Modus probiert, bei dem es ja keine präexistenten Cookies gibt. Auch dort klappt es bei mathefragen.de nicht.
Diese Frage melden
gefragt

Punkte: 45

 

Danke Jörg, gut gesehen! wir sind dran. @joergwausw   ─   doni 17.08.2021 um 20:03

Ich kann das bestätigen. Leider ist dies immer noch der Fall.   ─   lefagnard 09.09.2021 um 14:36
Kommentar schreiben
2 Antworten
0
Hey Jörg, 

vielen Dank nochmal dass du hier proaktiv die Frage gestellt hast! <3 

Wir haben nun endlich die Lösung gefunden. Es lag an fehlende Cookie-Permissions, die durch CookieBot standardmäßig blockiert wurden. Diese sind jetzt nicht mehr blockiert und müssen vom Nutzer aktiv zugelassen werden. 

Danke nochmal für Eure Geduld und so schön, dass Ihr immer da seid! 

<3
Diese Antwort melden
geantwortet

Punkte: 10

 

Bedeutet das, dass die Seite so programmiert sein muss, dass es ohne erlaubte Cookies nicht geht? Es ging ja vorher auch. Also sind die Cookies nicht wirklich notwendig - und hier geht es auch nach wie vor. Und zwar ohne Cookies.

Bei mathefragen waren laut Firefox-Einstellungen aktuell 3 Cookies gespeichert (ich hatte nur das Minimum abgenickt), bei metha-fragen sogar nur 2.

mathefragen.de lässt mich mit den 3 Cookies nach wie vor keine Kommentare schreiben.

Es gab auch keine Information, dass ich jetzt irgendetwas ändern müsste. Das bedeutet, dass alle die, die Probleme haben, immer noch Probleme haben werden, wenn sie keine Infos bekommen.

-> Nach Löschen der Cookies und Neuanmeldung soll ich auf einmal 69(! Wenn ich mich nicht verzählt habe) pauschal akzeptieren. Das sehe ich nicht ein.

Ein laut DSGV vorgeschriebenes Opt-In (und nicht: Opt out) ist nicht vorgesehen, weil ich z.B. Statistik- und Marketing-Cookies offensichtlich nicht abwählen kann).

Ich empfehle dringend, die Seite wieder so zu programmieren, dass sie auch wie zuvor ohne Cookies funktioniert (vom Session-Cookie abgesehen). Es muss erlaubt werden, die Opt-ins zu selektieren.

Mittlerweile komme ich nicht einmal mehr an meine Nachrichten dran.

Dazu kommt, dass die Cookie-Bot-Einblendung den Zugang zum Impressum überdeckt - auch das ist vermutlich problematisch und kann möglicherweise sogar zu Abmahnungen führen (ich bin kein Anwalt - ich habe nur schon von diversen irren Abmahnungsideen gehört).
  ─   joergwausw 19.08.2021 um 21:39

Sehe ich genauso, mit der DSGV nicht verträglich. Ich hoffe, dass bald wieder der alte funktionierende Zustand hergestellt wird. Ich verstehe gar nicht, warum ein funktionierendes System so upgedatet wird, dass wichtiges nachher nicht mehr geht.   ─   mikn 20.08.2021 um 12:11

Das Problem liegt leider nicht direkt in den Cookies. Der Cookiebot denkt, dass bestimmte Datein verdächtig sind, obwohl sie gar nicht in die Kategorie der zu meidenden Cookies fallen. Deshalb kann der Browser auf diese Daten nicht zugreifen und bestimmte Funktionen funktionieren nicht.
Deshalb müssen wir leider vorübergehend alle Cookies zulassen, damit die Seite überhaupt funktionieren kann. Es ist also ein Bug unserer Seite der vorher nicht aufgefallen ist, weil wir die Auswahl in den Cookies ja noch nicht so lange implementiert haben.
Deshalb wird der fix dieses Bugs auch leider etwas dauern. Wir arbeiten aber mit Hochdruck daran uns eine Möglichkeit einfallen zu lassen, wie wir das beheben können.

Tut uns wirklich sehr Leid, dass dies momentan die einzige Möglichkeit ist.
  ─   christianstrack 20.08.2021 um 19:08

1
Solange es hier funktioniert, kann ich nicht glauben, dass der gleiche Zustand wie hier bei mathefragen.de nicht hergestellt werden kann.

Ein Session-Cookie reicht doch eigentlich. Wofür braucht man überhaupt einen Cookie-Bot? Wofür soll das Tracking denn gut sein? Die Statistik, die man braucht, kann man auch durch Implementieren von Zählern im Skript der Webseite hinkriegen - bzw. werden sowie mitgezählt und angezeigt. Das ist anonym und man teilt keine Daten mit Datenkraken.

Und im Hintergrund automatisch "alle Cookies zulassen", also z.B. neue Cookies anderer Anbieter zu implementieren, ohne den Nutzer darüber zu informieren, der vor Monaten mal einer damals aktuellen, vorgegebenen Liste zugestimmt hat, dürfte vermutlich auch nicht ok sein.

Hier steht gerade eine Menge Vertrauen auf dem Spiel - nicht zu vergessen die Probleme der User, bei denen es nicht funktioniert.

Vielleicht hilft einfach ein Downgrade des Cookiebots, wenn der das Problem ist.

(oder man registriert die Domain www.funktionierts-noch-mit-fragen.de und probiert erstmal aus, ob die Hauptfunktionen noch funktionieren - bevor die Änderung bei der größten der vorhandenen Communities live geschaltet wird. So viel von mir vom komfortablen Sofa.)
  ─   joergwausw 21.08.2021 um 06:32

So ein Tool wie Cookie Bot braucht man, damit die User einsehen können und (bestenfalls) entscheiden können, welche Cookies genutzt werden.
Wie sich herausgestellt hat, liegt der Bug sogar bei Cookie Bot selbst (https://support.cookiebot.com/hc/en-us/community/posts/360006800679-Angular-application-fails-to-load-when-cookiebot-is-enabled)
Hier auf Meta-Fragen ist noch eine ältere Version vom Cookie Bot. Deshalb ist der Fehler hier nicht anscheinend nicht aufgetreten.

Die Cookies wurden nicht im Hintergrund einfach zugelassen. Das würden wir niemals tun. Jeder musste die Cookies neu bestätigen. Nur ohne die Bestätigung klappt es momentan leider eben nicht.
  ─   christianstrack 23.08.2021 um 15:43

Da haben wir es doch: Downgrade auf die alte Version ist die Lösung!
(oder man ersetzt das "powered by" einfach mal durch "malfunctioned by")

Wenn es von Anfang an die gleichen Cookies waren wie jetzt, muss natürlich später nicht mehr fragen. Wenn aber neue Cookies mit der Zeit dazugekommen sind, dann schon... bzw. zumindest informieren, dass es neue Cookies gibt und der Nutzer seine Auswahl überprüfen soll.

Bei mir war es so, dass ich nichts zulassen musste - es hat aber auch nichts funktioniert. Ohne Erklärung. Ich musste sogar selbstständig alte Cookies löschen, damit die Frage erscheint (die immer noch das Impressum verdeckt, weil ich sie nicht beantworte, solange mir die Möglichkeiten nicht gefallen)
  ─   joergwausw 24.08.2021 um 03:00

Ja wird vermutlich die Lösung sein. Unser Coder ist dran und guckt sich an ob das funktioniert.

Ok das ist natürlich schlecht. Bei mir hat sich das zurückgesetzt und ich wurde neu gefragt. Ich werde das mal weiterleiten.
  ─   christianstrack 25.08.2021 um 11:49

Kommentar schreiben

0
Ich denke, dass passt als Ergänzung noch gut dazu: 

Mir ist aufgefallen, dass bei der Verwendung von "<" in Kommentaren und im Mathemodus Probleme auftreten, da das Zeichen als Teil eines HTML-Tags interpretiert wird, wenn nach dem Zeichen kein Leerzeichen folgt. Damit verschwindet dann auch der gesamte folgende Text. Man muss also X< Y schreiben, anstelle von X<Y. Ist ein kleiner Schönheitsfehler, sollte aber irgendwie behoben werden. Tritt bei Antworten nicht auf.
Diese Antwort melden
geantwortet

Punkte: 32

 

Habe ja aktuell kein Javascript auf mathefragen.de, d.h. die Formatierungsoptionen beim Antworten gibt es nicht. Dort kann ich mir mit HTML-Tags helfen - ich vermute, dass es dann bei den Antworten auch auftritt. Javascript dürfte dort intern die Vergleichszeichen durch die HTML-Tags ersetzen (wenn es denn läuft)...   ─   joergwausw 21.08.2021 um 21:12

Habe ich weiter gegeben. Danke :)   ─   christianstrack 23.08.2021 um 15:44

Scheint ein Bug bei MathJax zu sein: https://www.tuhh.de/MathJax/test/sample-dynamic-2.html
Allerdings hat Stackoverflow das irgendwie gelöst. Wir gucken wie wir das fixen können :)
  ─   christianstrack 25.08.2021 um 11:51

Kommentar schreiben